Shop Categories

X

Black category on woocommerce

Home Forums Agama Pro Black category on woocommerce

Topic Resolution: Resolved

Tagged: 

Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #6698
    Igor
    Participant

    Hello, we are having a intermitent problem with Woocommerce at bezar.es

    Categories, sometimes, appear blank (there is a flash of the categories content with a wrong image dimmension that disappear.

    Sometimes F5 bring back the expected result, sometimes is needed to regenerate permalinks.

    At the same time, the problem can occur in a computer and another computer see it just fine.

    The same problem doesnt happen if we change the theme for Twentyseventeen.

    Website: https://bezar.es/
    Store webpage: https://bezar.es/store/

    Content flash: https://drive.google.com/open?id=12XfywVFmMne4cwH8sfHpFw7nZSH1QI-L
    Blank category (1 second after the previous screenshot): https://drive.google.com/open?id=12XfywVFmMne4cwH8sfHpFw7nZSH1QI-L

    Best Regards,
    Igor

    #6699
    Zex
    Moderator

    Hello Igor,

    I checked your site and found that you probably have some problem with the “CLOUDFLARE/ Rocket Loader” plugin, so I suggest you to temporarily disable this plugin and check again.

    If after you tried this, the problem still persists, please contact us again.

    Regards

    #6700
    Igor
    Participant
    This reply has been marked as private.
    #6701
    Igor
    Participant

    Thanks, you are correct, cloudflare wqas disabled and the plugin still enabled, will try that (ignore the previous reply, had made it before seeing your reply.

    #6702
    Igor
    Participant

    Ok, disabled Cloudflare plugin… cleaned Cometcache and the browser cache’s, went to https://bezar.es/store/

    Same result. 🙁

    #6703
    Igor
    Participant

    FORGOT A IMPORTANT INFO: THIS ISSUE JUST HAPPENS WHEN USING GOOGLE CHROME.

    Maybe it can help to find the root cause.

    #6704
    Jerry
    Keymaster

    Hello Igor,

    I have made few changes on your website, check if everything is working ok now.

    Regards

    #6705
    Igor
    Participant

    Its working fine, but the thumbnails are huge (and ugly), now…
    They are also inconsistent as different products images have different size.

    Don’t think we can use it this way. 🙁

    #6706
    Jerry
    Keymaster

    Send few screens and links what is huge and where so i can resolve that too.

    Regards

    #6707
    Igor
    Participant

    1 – How it was (nice layout but with the blank store bug): https://drive.google.com/open?id=1FZZXOg5taEBPb72Dm8W-Tmd93DdljqPT
    2 – How it is (ugly but works fine): https://drive.google.com/open?id=16PayEn-itL8ArQ3wA0I-3BnRrn56GFNe

    Any way to make it look like 1 without breaking the store in google Chrome?

    Pd.: In the title I misspelled “black” instead of “Blank” just in case someone look info about this same problem will not understand it.

    #6708
    Jerry
    Keymaster

    How i see it on my Chrome right now:
    http://prntscr.com/h879ee

    Please clear your browser cache and refresh shop page.

    Regards

    #6709
    Igor
    Participant

    OK, NOW I UNDERSTAND THE PROBLEM, NOW… (WRITING IT BELOW SO ANYONE WITH THE SAME PROBLEM CAN FIND THE SOLUTION)

    Woocommerce has a built in way to set the catalog’s thumbnail size: woocommerce-> setting-> products-> display-> catalog images

    We resized it using CSS, instead.

    So it was loading the 350×350 images and resizing it through CSS to 190×190 and Chrome didnt like it.

    You removed the CSS resizing to fix the issue so the images turned into 350×350 pixels.

    Just changing the setting at its correct place “woocommerce-> setting-> products-> display-> catalog images” fixed the issue.

    Many thanks for your quick solution!

    #6710
    Jerry
    Keymaster

    I’m glad everything is ok now.

    I must notice that you have too much active plugins (46) which is very good recipe for big mess in almost every area of website and almost every issue you have with your website it is connected with some active plugin which throws some jQuery error or it just incompatible with theme (coded by inexperienced programmer).

    My suggestion is that you start reducing active plugins and turn off or even delete ones you can be without. So many active plugins caused your website to load very slowly even with caching plugin turned on.

    This is just quick analysis for you from my view.

    Regards

    #6711
    Igor
    Participant

    Many thanks for your suggestion, we will disable the plugins that aren’t critical.

Viewing 14 posts - 1 through 14 (of 14 total)
  • The topic ‘Black category on woocommerce’ is closed to new replies.