Shop Categories

X

Portfolio pagination error

Home Forums Agama Pro Portfolio pagination error

Topic Resolution: Resolved
Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #8942
    akira78
    Participant

    Hi everybody,
    I’m configuring Agama Pro and there is a little problem: when I try to see the second page of my portfolio, a 404 error page appears!
    Before starting to add posts to the portfolio, I changed the portfolio page slug from “agama_portfolio” to “portfolio”. I tried to change back the path to “agama_portfolio” but when I do this, all that I’ve added in the portfolio disappears…
    How can I solve this problem?
    Thanks for your attention.

    #8944
    Zex
    Moderator

    Hello akira78!

    Please, Try next:
    Go to:Customizing->Portfolio, and enter agama_portfolio as the Portfolio Page Slug.

    https://prnt.sc/japafv
    next,
    Go to: Dashboard->Pages and edit the Portfolio Page.
    Then edit the Portfolio page permalink.

    https://prnt.sc/japd2b

    On the end of the link, enter “portfolio” instead of the “agama_portfolio”.

    https://prnt.sc/japc9l

    Update the page and check the portfolio page again.
    your portfolio items now should be shown.

    Last step:

    Go to: Dashboard->Pages and edit the Portfolio page permalink once again.
    Now rename it again to the “agama_portfolio”. and update the page.

    Now the pagination should work.

    If the above steps didn’t helped you, please give me your Website address and WP login credentials in the private reply (check the “Set as private reply” checkbox below the post, so I can try to fix that issue for you.

    Best Regards

    • This reply was modified 4 years, 7 months ago by Zex.
    #8949
    akira78
    Participant
    This reply has been marked as private.
    #8974
    Zex
    Moderator

    Hello akira78!

    Actually, I have found that we have some bug with the portfolio pagination, and we must rewrite the code for it.(It will be fixed in the next theme update.)

    For now, I disabled the pagination on the portfolio page and increased the items per page value, so all items are displayed on one page.
    In that case, the filter works well. (Because the filter works for each page separately, and that is we want to change).

    1. Done.

    2. I increased the padding-top value on the portfolio page to extend the page, so you do not have a bouncing effect.

    3. Explained at the beginning

    4. I have installed and activated an Envira Gallery lite plugin and solved the problem.
    Also, I created a test gallery (Gallery1) for the “Inferriate porte e finestre con taglio al plasma” portfolio item.(https://www.ferroeingegnorieti.it/portfolio/inferriate-porte-e-finestre-con-taglio-al-plasma/)
    Please, check the next guides to learn how to make a gallery :
    https://enviragallery.com/docs/creating-first-envira-gallery/.

    https://www.youtube.com/embed/F9_wOefuBaw?autoplay=1&rel=0

    P.S: You can use some other Gallery plugin too if you don’t satisfied with this one I installed.
    (there is another good plugin to test:https://wordpress.org/plugins/final-tiles-grid-gallery-lite/)

    Best Regards

    • This reply was modified 4 years, 7 months ago by Zex.
    • This reply was modified 4 years, 7 months ago by Zex.
    #8977
    akira78
    Participant

    Hi Zex, thank you for your quickly reply.

    Hope that the problem with the portfolio pagination will be solved soon because I have a lot of items more to add and a page with about 40/50 item can be a little slow to charge…for this reason I activated the pagination.

    I still see the “bouncing” effect when there is only 1 row of items.

    To add a gallery plug in is the only solution?Because I have to add a gallery for each portfolio item and use the wordpress native gallery is the simplest and fastest solution for me!Creating each gallery in a different plugin and copying the code every time must be a nightmare when you have to do it for 40/50 times…

    Another thing: always in portfolio page, if you take a look to it in mobile version, the categories buttons are not so good to see (too much large, going over the right border). Maybe a different view could be better…

    Thank you again and regards.

    #8979
    Zex
    Moderator

    Hi,

    Well.. you are right,

    There is the simple and fast way to add a Gallery to the portfolio item:
    I have enabled the WP Bakery page builder on the portfolio, so you can edit the portfolio item with the WP Bakery Backend editor and use the “Media grid” shortcode to add the gallery. (I have already added the Gallery in the “Inferriate porte e finestre con taglio al plasma” portfolio item.(https://www.ferroeingegnorieti.it/portfolio/inferriate-porte-e-finestre-con-taglio-al-plasma/))

    https://prnt.sc/jau0b8

    So you can now delete the Envira Gallery lite plugin.

    Next, “bouncing” effect happens only on the medium screens because of the little page content.

    I have increased a padding value on the bottom of the page to avoid this.

    https://prnt.sc/jau1w0

    It looks so because you have an odd number of categories and long category names. Maybe we should fix this too…

    Regards

    #8980
    Zex
    Moderator

    Hello akira78!

    I have fixed the Lightbox Gallery issue (installed the “Simple Lightbox” plugin) and that solved the problem.So you don’t need even to use the WP Bakery plugin, as I recommended you in the previous post
    Just normally add a Gallery and chose a Link to “File media” in Gallery settings on the right side.

    https://prnt.sc/jaw8v9

    P.S: Because the Gallery now works, I have deactivated an Envira Gallery Lite plugin and removed the WP Bakery media grid shortcode from the “Inferriate porte e finestre con taglio al plasma” portfolio item.

    Regards

    • This reply was modified 4 years, 7 months ago by Zex.
    #8984
    akira78
    Participant

    Thank you very much for your help.
    I’ll wait for the next theme update to use again the portfolio pagination…

    Have a nice day! 🙂

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.