Shop Categories

X

problems with Featured Image in Post

Home Forums Agama Pro problems with Featured Image in Post

Topic Resolution: Resolved
Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #8700
    ricottime
    Participant

    Dear Support Team,
    I have problems with the size and position of the Featured Images in Posts, when Featured Thumbnail option is ON (in Customising > Blog > Single Post)

    – the image is very big in the Post (when the Format of the Post is Standard): how to change/modify/adapt the size of the Featured Image in the Post?
    – the image is big also if the Format of the Post is Aside, or Image, or any other type of format, moreover the image may overlap the text of the post: how to change/modify/adapt the size and the position of the Featured Image in the Post, in this case?

    thanks a lot!!!
    marco

    #8702
    Zex
    Moderator

    Hello, Marco!

    You can modify the featured image size with next custom CSS code:

    /*Single-post Featured image size*/
    
    .single-post .entry-header
     {
      max-width:400px;
      margin:auto
    }

    Change the max-width value per your needs.

    Best Regards

    #8703
    ricottime
    Participant

    thx a lot Zex!

    can you solve also the problem of the overlapping of the image on the text of the post, when Aside, or Image (or any other type of format) is selected for the post, and when the browser is resized-reduced?…
    moreover, can we change the way how Agama manage the featured images in the post? Agama cuts the top and the bottom of the image, leaving a rectangular image

    thank you once more!
    marco

    #8706
    Zex
    Moderator

    Hello, Marco!

    Follow the steps below, if you want to show an uncropped image in the posts:

    1. Open the theme Editor (Dashboard->Appearance->Editor)

    2.Chose to edit an Agama Pro theme in the top-right corner.

    3.On the right side, find the agama-functions.php file, located on the framework folder.

    4. click on an agama-functions.php file to edit it.

    5.In the main window, scroll down to the line #39 and comment the line
    add_image_size( 'blog-large', 776, 9999, true );
    (add a // sign in front of the line of the code).

    6. Click on the “Update file” button to save the changes.

    https://prnt.sc/j2xew3

    next,

    7. Go to: Dashboard->Plugins, search for Simple Image Sizes plugin. Install and activate it.
    https://prnt.sc/j2xfpl

    8.Add the Featured image to the post.
    https://prnt.sc/j2xggf
    then Update the post.

    9.Check the post,
    If your Featured image is cropped, go back, edit the post and now, below the featured image, you should see a “Regenerate image size” link.
    https://prnt.sc/j2xj3b

    Click on that link to regenerate your image size, update your post and check again.
    Now your image should be uncropped.

    I hope you understand the procedures I have provided.
    If you have any further questions, please contact me.

    I didn’t find the problem with the overlapping.
    Please, Give me a link to the post where a problem occurs.

    Best Regards

    • This reply was modified 4 years, 7 months ago by Zex.
    #8985
    ricottime
    Participant

    Dear Zex, thanks a lot!

    a couple of requests:
    1. here is the link to the post (format: Aside) where the featured image is overlapping the post content:

    prof. Marco Ricotti

    2. I would like to have the chance to select the size of the featured image in the post, for example:
    – here, the “full width” image is perfect (the image is anyway originally wide):

    Mochovce (SK)


    – while here, I would like to avoid the image occupying the full width of the post:

    prof. Antonio Cammi

    prof. Marco Ricotti

    another option could be to have simply chance to show the featured image “as is”, I mean with its original size (so I will have large images if they are wide, e.g. 1200×600, small images is they are small, e.g. 250×250)

    thanks a lot Zex!!!!!
    ciao
    marco

    #8990
    Zex
    Moderator

    Hello Marco!

    The easiest way to get what you want is to turn off the “Featured thumbnails” in the Single Post page in Customize->Blog->Single Post
    https://prnt.sc/jbnfy1
    (I already did that for you),
    Then upload the same image as your featured image, in the post content, and set the size and alignment as you wish.

    Maybe the next video will help you with that.
    Working with images

    Please check all posts, and add an image where it’s missing since I turned off a “Featured thumbnails”.

    Best Regards

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.